Resetting Xeo

In case the Xeo settings have accidentally been set, or unexpected malfunctions occur, a factory reset can be useful. After the reset, functionality will be improved and you can re-install your Xeo system with all individual settings right from the start.

Note: A reset should always be performed with all Xeo loudspeakers and the Xeo Transmitter / Xeo Hub / Xeo Connect.

Resetting the Xeo loudspeaker

  1. ​Switch the loudspeaker on using the remote control.
  2. Point the remote control to the loudspeaker and hold the ON button for more than 5 seconds.
  3. The LED on the speaker will begin flashing red-blue.
  4. ​Release the ON button.
  5. The LED stops flashing.

The loudspeaker is now set back to the factory default settings:

  • Channel: A
  • Frequency mode: Frequency Switching
  • Input: 1
  • Volume level: high


Resetting Connect

  1. Remove all signal cables, but leave the Connect powered by either the 5V power adapter or USB power.
  2. Take the Connect in your hand.
  3. Press and hold the buttons Bluetooth Setup and WiFi Setup for about 5 seconds.
  4. The LEDs on the front will go out, release the buttons and wait until Connect has rebooted.

The Connect is now set back to the factory settings.


Resetting Hub / Xeo Transmitter

  1. Remove all signal cables, but leave the Hub powered by either the 5V power adapter or USB power.
  2. Take the Hub in your hand.
  3. Switch the ABC Id switch quickly between A and B settings, at least 10 times.
  4. The LED on the Hub starts flashing red-blue.
  5. Stop switching when in A position. The LED stops blinking.

The Hub is now set back to the factory settings:

  • Channel: A
  • Frequency mode: Frequency
  • Switching Input: 1

 

Have more questions? Submit a request